import re
regex = re.compile(r"\b(?:3|4|5|6|7|8|9|10|11|12|13|14|15|16|17|18|19|20|21|47|45|68|100|104),?", flags=re.MULTILINE)
test_str = "4,6,7,28,9,8,12"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")