$re = '/\b(?:3|4|5|6|7|8|9|10|11|12|13|14|15|16|17|18|19|20|21|47|45|68|100|104),?/m';
$str = '4,6,7,28,9,8,12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);