const regex = /(\w)( )(\w)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w)( )(\\w)', 'gm')
const str = `"\\|\\s*language\\s*=\\s*Freaslainnis Iartharach\\b" "|language=fy" \\`;
const subst = `\1\\\2\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);