using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"From:\s*(?<name>[^<]*)(?:<(?<email>[^><]+)>)?(?:\nDate:\s*(?<date>.+))?(?:\nSubject:\s*(?<subject>.+))?";
string input = @"Regards
Ankit Balyan
---------- Forwarded message ---------
From: John Doe <john.doe@gmail.com>
Date: Thu, Aug 23, 2018 at 04:00 PM
Subject: my Email Subject
To: Ankit Balyan <sf.ankit@gmail.com>
Hi,
This is for testing purpose
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}