re = /From:\s*(?<name>[^<]*)(?:<(?<email>[^><]+)>)?(?:\nDate:\s*(?<date>.+))?(?:\nSubject:\s*(?<subject>.+))?/m
str = 'Regards
Ankit Balyan
---------- Forwarded message ---------
From: John Doe <john.doe@gmail.com>
Date: Thu, Aug 23, 2018 at 04:00 PM
Subject: my Email Subject
To: Ankit Balyan <sf.ankit@gmail.com>
Hi,
This is for testing purpose
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end