use strict;
my $str = 'Regards
Ankit Balyan
---------- Forwarded message ---------
From: John Doe <john.doe@gmail.com>
Date: Thu, Aug 23, 2018 at 04:00 PM
Subject: my Email Subject
To: Ankit Balyan <sf.ankit@gmail.com>
Hi,
This is for testing purpose
';
my $regex = qr/From:\s*(?<name>[^<]*)(?:<(?<email>[^><]+)>)?(?:\nDate:\s*(?<date>.+))?(?:\nSubject:\s*(?<subject>.+))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}