import re
regex = re.compile(r"From:\s*(?<name>[^<]*)(?:<(?<email>[^><]+)>)?(?:\nDate:\s*(?<date>.+))?(?:\nSubject:\s*(?<subject>.+))?", flags=re.MULTILINE)
test_str = ("Regards\n"
"Ankit Balyan\n\n\n"
"---------- Forwarded message ---------\n\n"
"From: John Doe <john.doe@gmail.com>\n"
"Date: Thu, Aug 23, 2018 at 04:00 PM\n"
"Subject: my Email Subject\n"
"To: Ankit Balyan <sf.ankit@gmail.com>\n\n\n"
"Hi,\n\n"
"This is for testing purpose\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")