#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\[\w+\]){1,2}\s(.*?)\s-\s(\d+)?(v\d+)?(\s(\(\w+p\)|(\[\w+p\]))?){1,2}.*$"
Local $sString = "[SubsPlease] Horimiya - 01v2 (1080p) [36C95A42].mkv" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[SubsPlease] Horimiya - 01 (1080p) [36C95A42].mkv" & @CRLF & _
"" & @CRLF & _
"[HorribleSubs] 3-gatsu no Lion - 36 [720p].mkv" & @CRLF & _
"" & @CRLF & _
"[SubsPlease] Boruto - Naruto Next Generations - 168 (480p) [D05AE2DF].mkv" & @CRLF & _
"" & @CRLF & _
"[SubsPlease] Boruto - Naruto Next Generations - 168 [480p] [D05AE2DF].mkv" & @CRLF & _
"" & @CRLF & _
"[GHOST][720p] A Certain Scientific Railgun T - 24 [BD HEVC 10bit Dual Audio AC3][C3EBD997].mkv"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")