import Foundation
let pattern = #"^(\[\w+\]){1,2}\s(.*?)\s-\s(\d+)?(v\d+)?(\s(\(\w+p\)|(\[\w+p\]))?){1,2}.*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[SubsPlease] Horimiya - 01v2 (1080p) [36C95A42].mkv
[SubsPlease] Horimiya - 01 (1080p) [36C95A42].mkv
[HorribleSubs] 3-gatsu no Lion - 36 [720p].mkv
[SubsPlease] Boruto - Naruto Next Generations - 168 (480p) [D05AE2DF].mkv
[SubsPlease] Boruto - Naruto Next Generations - 168 [480p] [D05AE2DF].mkv
[GHOST][720p] A Certain Scientific Railgun T - 24 [BD HEVC 10bit Dual Audio AC3][C3EBD997].mkv
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)