use strict;
my $str = '[SubsPlease] Horimiya - 01v2 (1080p) [36C95A42].mkv
[SubsPlease] Horimiya - 01 (1080p) [36C95A42].mkv
[HorribleSubs] 3-gatsu no Lion - 36 [720p].mkv
[SubsPlease] Boruto - Naruto Next Generations - 168 (480p) [D05AE2DF].mkv
[SubsPlease] Boruto - Naruto Next Generations - 168 [480p] [D05AE2DF].mkv
[GHOST][720p] A Certain Scientific Railgun T - 24 [BD HEVC 10bit Dual Audio AC3][C3EBD997].mkv';
my $regex = qr`^(\[\w+\]){1,2}\s(.*?)\s-\s(\d+)?(v\d+)?(\s(\(\w+p\)|(\[\w+p\]))?){1,2}.*$`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}