import re
regex = re.compile(r"^(\[\w+\]){1,2}\s(.*?)\s-\s(\d+)?(v\d+)?(\s(\(\w+p\)|(\[\w+p\]))?){1,2}.*$", flags=re.MULTILINE)
test_str = ("[SubsPlease] Horimiya - 01v2 (1080p) [36C95A42].mkv\n\n\n"
"[SubsPlease] Horimiya - 01 (1080p) [36C95A42].mkv\n\n"
"[HorribleSubs] 3-gatsu no Lion - 36 [720p].mkv\n\n"
"[SubsPlease] Boruto - Naruto Next Generations - 168 (480p) [D05AE2DF].mkv\n\n"
"[SubsPlease] Boruto - Naruto Next Generations - 168 [480p] [D05AE2DF].mkv\n\n"
"[GHOST][720p] A Certain Scientific Railgun T - 24 [BD HEVC 10bit Dual Audio AC3][C3EBD997].mkv")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")