#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)play\s+([^,]+?)\s*,|show\s+(.*?)\s+profile|show\s+(\d{4})\s+season\s+of\s+([^,]+?)\s*,|i(?:'m)?\s+.*?(?:\ba\b|\ban\b)\s+(\S+)"
Local $sString = "play demo-song, pattern: play {song}, " & @CRLF & _
"show hoizer profile, pattern: show {artist} profile" & @CRLF & _
"show 2019 season of GOT, pattern: show {year} season of {series}, " & @CRLF & _
"" & @CRLF & _
"PLAY demo-song, pattern: PLay {song}, " & @CRLF & _
"SHOW hoizer some other artists profile, pattern: show {artist} profile" & @CRLF & _
"show 2019 SEASON OF GOT , pattern: show {year} season of {series}, " & @CRLF & _
"" & @CRLF & _
"i am a student I AM A programmer i'm a suergeon pattern: I'm a {profession}, "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")