import re
regex = re.compile(r"play\s+([^,]+?)\s*,|show\s+(.*?)\s+profile|show\s+(\d{4})\s+season\s+of\s+([^,]+?)\s*,|i(?:'m)?\s+.*?(?:\ba\b|\ban\b)\s+(\S+)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("play demo-song, pattern: play {song}, \n"
"show hoizer profile, pattern: show {artist} profile\n"
"show 2019 season of GOT, pattern: show {year} season of {series}, \n\n"
"PLAY demo-song, pattern: PLay {song}, \n"
"SHOW hoizer some other artists profile, pattern: show {artist} profile\n"
"show 2019 SEASON OF GOT , pattern: show {year} season of {series}, \n\n"
"i am a student I AM A programmer i'm a suergeon pattern: I'm a {profession}, ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")