#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\d+\s*$)\d+.+$"
Local $sString = "Here goes some text. {tag} A wonderful day. It's soon cristmas." & @CRLF & _
"2 Happy 2019, soon. {Some useful tag!} Something else goes here." & @CRLF & _
"3 Happy ending. Yeppe! See you." & @CRLF & _
"4 " & @CRLF & _
"5 Happy KKK!" & @CRLF & _
"6 Happy B-Day!" & @CRLF & _
"7" & @CRLF & _
"8 Universe is cool!" & @CRLF & _
"9" & @CRLF & _
"10 {Tagish}." & @CRLF & _
"11" & @CRLF & _
"12 {Slugish}. Here goes another line. {Slugish} since this is a new sentence." & @CRLF & _
"13" & @CRLF & _
"14 endline." & @CRLF & _
"4 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")