re = /^(?!\d+\s*$)\d+.+$/m
str = 'Here goes some text. {tag} A wonderful day. It\'s soon cristmas.
2 Happy 2019, soon. {Some useful tag!} Something else goes here.
3 Happy ending. Yeppe! See you.
4
5 Happy KKK!
6 Happy B-Day!
7
8 Universe is cool!
9
10 {Tagish}.
11
12 {Slugish}. Here goes another line. {Slugish} since this is a new sentence.
13
14 endline.
4 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end