import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\d+\\s*$)\\d+.+$";
final String string = "Here goes some text. {tag} A wonderful day. It's soon cristmas.\n"
+ "2 Happy 2019, soon. {Some useful tag!} Something else goes here.\n"
+ "3 Happy ending. Yeppe! See you.\n"
+ "4 \n"
+ "5 Happy KKK!\n"
+ "6 Happy B-Day!\n"
+ "7\n"
+ "8 Universe is cool!\n"
+ "9\n"
+ "10 {Tagish}.\n"
+ "11\n"
+ "12 {Slugish}. Here goes another line. {Slugish} since this is a new sentence.\n"
+ "13\n"
+ "14 endline.\n"
+ "4 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}