const regex = /^(?!\d+\s*$)\d+.+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!\\d+\\s*$)\\d+.+$', 'gm')
const str = `Here goes some text. {tag} A wonderful day. It's soon cristmas.
2 Happy 2019, soon. {Some useful tag!} Something else goes here.
3 Happy ending. Yeppe! See you.
4
5 Happy KKK!
6 Happy B-Day!
7
8 Universe is cool!
9
10 {Tagish}.
11
12 {Slugish}. Here goes another line. {Slugish} since this is a new sentence.
13
14 endline.
4 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}