const regex = /url\(((?:\/[^\/()]+?)+?\.(gif|png|jpg|jpeg|svg|woff|eot|ttf))[^)]*\)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('url\\(((?:\\\/[^\\\/()]+?)+?\\.(gif|png|jpg|jpeg|svg|woff|eot|ttf))[^)]*\\)', 'gmi')
const str = `url(/var/www/synergicNetwork/app/webroot/img/mosaico.png) no-repeat center center fixed; color:#fff; background-size:cover; url(/var/www/synergicNetwork/app/webroot/img/mosaico.png) no-repeat center center fixed; color:#fff; background-size:cover;
url(/ghfdgh/glyphicons-halflings-regular.eot?#iefix) format('embedded-opentype'),url(/fonts/glyphicons-halflings-regular.woff)`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);