use strict;
my $str = 'url(/var/www/synergicNetwork/app/webroot/img/mosaico.png) no-repeat center center fixed; color:#fff; background-size:cover; url(/var/www/synergicNetwork/app/webroot/img/mosaico.png) no-repeat center center fixed; color:#fff; background-size:cover;
url(/ghfdgh/glyphicons-halflings-regular.eot?#iefix) format(\'embedded-opentype\'),url(/fonts/glyphicons-halflings-regular.woff)';
my $regex = qr/url\(((?:\/[^\/()]+?)+?\.(gif|png|jpg|jpeg|svg|woff|eot|ttf))[^)]*\)/mip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";