#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[^\\;\r\n]*(?:\\.[^\\;\r\n]*)*;){6}$"
Local $sString = "Number;Lastname or Company;Firstname;City;Postcode;Amount;" & @CRLF & _
"1;Trump;Donald;Washington;12345;4;" & @CRLF & _
"2;Bush;George;Washington;54321;1;" & @CRLF & _
"3;Lloyds\; and Firends;;11111;2;" & @CRLF & _
"4;Schuhmacher\;Frenzen\;Fettel; and Co;Company;Anywhere;22222;3;" & @CRLF & _
"5;Best\;Friends;Company\;Co;Nowhere;33333;4;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")