// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[^\\;\r\n]*(?:\\.[^\\;\r\n]*)*;){6}$").unwrap();
let string = "Number;Lastname or Company;Firstname;City;Postcode;Amount;
1;Trump;Donald;Washington;12345;4;
2;Bush;George;Washington;54321;1;
3;Lloyds\\; and Firends;;11111;2;
4;Schuhmacher\\;Frenzen\\;Fettel; and Co;Company;Anywhere;22222;3;
5;Best\\;Friends;Company\\;Co;Nowhere;33333;4;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}