use strict;
my $str = 'Number;Lastname or Company;Firstname;City;Postcode;Amount;
1;Trump;Donald;Washington;12345;4;
2;Bush;George;Washington;54321;1;
3;Lloyds\\; and Firends;;11111;2;
4;Schuhmacher\\;Frenzen\\;Fettel; and Co;Company;Anywhere;22222;3;
5;Best\\;Friends;Company\\;Co;Nowhere;33333;4;';
my $regex = qr/(?m)^(?:[^\\;\r\n]*(?:\\.[^\\;\r\n]*)*;){6}$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}