$re = '/(?m)^(?:[^\\\\;\r\n]*(?:\\\\.[^\\\\;\r\n]*)*;){6}$/';
$str = 'Number;Lastname or Company;Firstname;City;Postcode;Amount;
1;Trump;Donald;Washington;12345;4;
2;Bush;George;Washington;54321;1;
3;Lloyds\\; and Firends;;11111;2;
4;Schuhmacher\\;Frenzen\\;Fettel; and Co;Company;Anywhere;22222;3;
5;Best\\;Friends;Company\\;Co;Nowhere;33333;4;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);