#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[\(\[]"
Local $sString = "[[VALUE],[VALUE]+1) " & @CRLF & _
"" & @CRLF & _
"([VALUE],[VALUE]+1) " & @CRLF & _
"" & @CRLF & _
"([123abc.VALUE],[VALUE]+[[VALUE.123]) " & @CRLF & _
"" & @CRLF & _
"[,-25] " & @CRLF & _
"" & @CRLF & _
"[-25,] " & @CRLF & _
"" & @CRLF & _
"[25, 25)" & @CRLF & _
"" & @CRLF & _
"[-25, [VALUE] " & @CRLF & _
"" & @CRLF & _
"[123abc.VALUE] "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")