using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\(\[]";
string input = @"[[VALUE],[VALUE]+1)
([VALUE],[VALUE]+1)
([123abc.VALUE],[VALUE]+[[VALUE.123])
[,-25]
[-25,]
[25, 25)
[-25, [VALUE]
[123abc.VALUE] ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}