$re = '/^[\(\[]/';
$str = '[[VALUE],[VALUE]+1)
([VALUE],[VALUE]+1)
([123abc.VALUE],[VALUE]+[[VALUE.123])
[,-25]
[-25,]
[25, 25)
[-25, [VALUE]
[123abc.VALUE] ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);