const regex = /^[\(\[]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\(\\[]', 'g')
const str = `[[VALUE],[VALUE]+1)
([VALUE],[VALUE]+1)
([123abc.VALUE],[VALUE]+[[VALUE.123])
[,-25]
[-25,]
[25, 25)
[-25, [VALUE]
[123abc.VALUE] `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}