using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\/([^$]+)";
string input = @"http://subdomain.xx-xxxx-x.xxx.url.com/content/assets/750
http://subdomain.xx-xxxx-x.xxx.url.com/content/assets
http://subdomain.xx-xxxx-x.xxx.url.com/content/
http://subdomain.xx-xxxx-x.xxx.url.com/";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}