// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*\/([^$]+)").unwrap();
let string = "http://subdomain.xx-xxxx-x.xxx.url.com/content/assets/750
http://subdomain.xx-xxxx-x.xxx.url.com/content/assets
http://subdomain.xx-xxxx-x.xxx.url.com/content/
http://subdomain.xx-xxxx-x.xxx.url.com/";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}