import re
regex = re.compile(r".*\/([^$]+)")
test_str = ("http://subdomain.xx-xxxx-x.xxx.url.com/content/assets/750\n"
"http://subdomain.xx-xxxx-x.xxx.url.com/content/assets\n"
"http://subdomain.xx-xxxx-x.xxx.url.com/content/\n"
"http://subdomain.xx-xxxx-x.xxx.url.com/")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")