$re = '/.*\/([^$]+)/';
$str = 'http://subdomain.xx-xxxx-x.xxx.url.com/content/assets/750
http://subdomain.xx-xxxx-x.xxx.url.com/content/assets
http://subdomain.xx-xxxx-x.xxx.url.com/content/
http://subdomain.xx-xxxx-x.xxx.url.com/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);