# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\s*|\s*$//gm;t' <<< " Doe, John
111 W. 8th St Houston, TX 77448
"