re = /^\s*|\s*$/m
str = ' Doe, John
111 W. 8th St Houston, TX 77448
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result