$re = '/^\s*|\s*$/m';
$str = ' Doe, John
111 W. 8th St Houston, TX 77448
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;