use strict;
my $str = ' Doe, John
111 W. 8th St Houston, TX 77448
';
my $regex = qr/^\s*|\s*$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";