const regex = /[\-+]?\d*\.?\d+e[\-+]?\d+/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\-+]?\\d*\\.?\\d+e[\\-+]?\\d+', 'ig')
const str = `-8.67548e-017-.5e7,1e-5,11.125e-21.6e-4,1.05E+10+00000e33-1.233456e-7,6e-4,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}