import re
regex = re.compile(r"[\-+]?\d*\.?\d+e[\-+]?\d+", flags=re.IGNORECASE)
test_str = "-8.67548e-017-.5e7,1e-5,11.125e-21.6e-4,1.05E+10+00000e33-1.233456e-7,6e-4,"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")