re = /[\-+]?\d*\.?\d+e[\-+]?\d+/i
str = '-8.67548e-017-.5e7,1e-5,11.125e-21.6e-4,1.05E+10+00000e33-1.233456e-7,6e-4,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end