// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)[\-+]?\d*\.?\d+e[\-+]?\d+").unwrap();
let string = "-8.67548e-017-.5e7,1e-5,11.125e-21.6e-4,1.05E+10+00000e33-1.233456e-7,6e-4,";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}