import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w*(?<!ENABLED_)MYSTUFF\\w*";
final String string = "MYSTUFF\n"
+ "m_MYSTUFF\n"
+ "MYSTUFFIsGreat\n"
+ "allOf_MYSTUFF\n\n"
+ "ENABLED_MYSTUFF\n"
+ "m_ENABLED_MYSTUFF\n"
+ "ENABLED_MYSTUFFIsGreat\n"
+ "allOf_ENABLED_MYSTUFF";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}