$re = '/\w*(?<!ENABLED_)MYSTUFF\w*/';
$str = 'MYSTUFF
m_MYSTUFF
MYSTUFFIsGreat
allOf_MYSTUFF
ENABLED_MYSTUFF
m_ENABLED_MYSTUFF
ENABLED_MYSTUFFIsGreat
allOf_ENABLED_MYSTUFF';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);