using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\n]*?(.+?) ([^\n]+)";
string input = @"
Geneza 15:6 Avram a crezut pe Domnul, şi Domnul i-a socotit lucrul acesta ca neprihănire.
Geneza 12:2 Voi face din tine un neam mare şi te voi binecuvânta; îţi voi face un nume mare şi vei fi o binecuvântare.
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}