const regex = /[^\n]*?(.+?) ([^\n]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\n]*?(.+?) ([^\\n]+)', 'g')
const str = `
Geneza 15:6 Avram a crezut pe Domnul, şi Domnul i-a socotit lucrul acesta ca neprihănire.
Geneza 12:2 Voi face din tine un neam mare şi te voi binecuvânta; îţi voi face un nume mare şi vei fi o binecuvântare.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}