$re = '/[^\n]*?(.+?) ([^\n]+)/';
$str = '
Geneza 15:6 Avram a crezut pe Domnul, şi Domnul i-a socotit lucrul acesta ca neprihănire.
Geneza 12:2 Voi face din tine un neam mare şi te voi binecuvânta; îţi voi face un nume mare şi vei fi o binecuvântare.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);