import re
regex = re.compile(r"[^\n]*?(.+?) ([^\n]+)")
test_str = ("\n\n"
"Geneza 15:6 Avram a crezut pe Domnul, şi Domnul i-a socotit lucrul acesta ca neprihănire.\n\n\n\n"
"Geneza 12:2 Voi face din tine un neam mare şi te voi binecuvânta; îţi voi face un nume mare şi vei fi o binecuvântare.\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")