import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^A-Za-z]";
final String string = "asdfasdf\n"
+ "1234\n"
+ "asdf\n"
+ ".,f/24324\n"
+ "o'brien\n"
+ "wolf\n"
+ "cattle\n"
+ "Manatee";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}