re = /[^A-Za-z]/
str = 'asdfasdf
1234
asdf
.,f/24324
o\'brien
wolf
cattle
Manatee'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end