using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^/(((?!/).)+)-(\d+)\.html$";
string substitution = @"/$3/$1-$3.html;";
string input = @"/foo-bar-article-9888--------1234.html";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}