$re = '/^/(((?!/).)+)-(\d+)\.html$/';
$str = '/foo-bar-article-9888--------1234.html';
$subst = "/$3/$1-$3.html;";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;