re = /^\/(((?!\/).)+)-(\d+)\.html$/
str = '/foo-bar-article-9888--------1234.html'
subst = '/$3/$1-$3.html;'
result = str.sub(re, subst)
# Print the result of the substitution
puts result